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PRz 
 

MODELE OBIEKTÓW STEROWANIA 
 

Bilans masy. Zbiornik z wpływem pod ciśnieniem hydrostatycznym. Bilans energii – 

podgrzewacz. Opóźnienie. Napięciowe sterowanie silnikiem DC. Sterowanie prądowe.  
 

 

BILANS MASY 
 

1. Metodologia Maxwella    (1868) 

 

 Tok postępowania 

1) Ułożyć równania dynamiki układu regulacji i zbadać jak zależą ich rozwiązania 

(przebiegi) od nastaw regulatora występujących we współczynnikach równań. 

2) Wybrać takie nastawy, które dają najlepsze przebiegi ze względu na kształt i 

prędkość.  
 

Punktem wyjścia jest ułożenie równania regulowanego obiektu (model matematyczny). 

Modelowanie, czyli układanie równań, opiera się o podstawowe prawa fizyki, 

termodynamiki, kinetyki chemicznej itp. Dla potrzeb automatyki wystarcza umiarkowana 

dokładność modelowania. Ważną zaletą układów ze sprzężeniem zwrotnym jest odporność 

na niedokładności modelowania. 
 

 Podstawowy bilans 

Bilans masy dotyczy wszelkich obiektów z przepływem cieczy, gazów, par, materiałów 

sypkich –  zbiorniki, mieszalniki, kotły, reaktory itp. 
 

 hAVM  , 

 

gdzie w przypadku zbiornika: 

M – masa cieczy, A – powierzchnia przekroju zbiornika 

V – objętość, h – wysokość słupa cieczy 

 – gęstość  
 

Równanie bilansu ma postać 
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ii qq
dt

dh
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qi, qj  –  przepływy objętościowe  (m
3
/s) 

 

 

2. Zbiornik z pompą opróżniającą 
 

 Dane liczbowe: 

 

A = 2 m
2
 

wywe qq    – średnie przepływy 

A 

h 

qwe qwy 
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 Równanie bilansu 
 

,:  wywe qq
dt

dh
A

dt

dM
                   wywe qq

dt

dh
A   

)(
1

wywe qq
Adt

dh
  

 

 

3. Transformata Laplace’a (transformacja) 
 

 Transformata Laplace’a pozwala zastąpić liniowe równanie różniczkowe o stałych 

współczynnikach równaniem algebraicznym w dziedzinie zmiennej zespolonej s 

nazywanej operatorem Laplace’a. 

W  js   część rzeczywista   reprezentuje tłumienie, a część urojona   – 

częstotliwość. 

Rozwiązywanie równań algebraicznych jest prostsze niż rozwiązywanie równań 

różniczkowych. Rozwiązanie w postaci czasowej otrzymuje się korzystając z wzorów 

podanych w tabelach odwrotnej transformaty Laplace’a. Pakiety komputerowe 

wspomagające projektowanie na ogół wymagają danych w notacji Lapalce’a.  

 

 Definicja transformaty Laplace’a funkcji f(t) 
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tfLdtetfsF st  


  

gdzie f(t) nie rośnie szybciej niż wykładniczo i f(t)=0 dla t<0. 

 

 Przykład – stała a 
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a    –  T  jest nazywane stałą czasową. 

 

 Transformata pochodnej (całkowanie „przez części”) 
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4. Transmitancja obiektu 

 

 Transformacja Laplace’a obydwu stron równania poziomu przy 00 h : 
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Transmitancja jest stosunkiem wyjścia do wejścia w dziedzinie operatora Laplace’a s 

i określa własności dynamiczne obiektu lub układu regulacji automatycznej. 

 

 Transmitancja całkująca 

Całkowanie względem czasu równania poziomu: 
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   – w ogólnym przypadku. 

 

 Schemat blokowy 
 

 

 

 

 

      Obiekt całkujący (integrator) 

 

5. MATLAB – program tekstowy 
 

 Kod 
 

 

l –  licznik transmitancji 

m –  mianownik 

t –  czas 

y –  wyjście 

step( ) – odpowiedź na skok jednostkowy 

 

 

 

sA
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- + Qwe 
Qwy 
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 Wykres – plot( ) 
 

 
 

Różnica między dopływem a odpływem powoduje ciągłą zmianę poziomu. Układu 

sterowania takim obiektem nie wolno wyłączać, bo zbiornik albo zostanie przelany, 

albo zupełnie opróżniony. 
 

 

6. SIMULINK – schemat graficzny 

 

 Ikona    lub komenda simulink 

 

 

 

Biblioteki 
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 File > New > Model  lub lewa ikona (Simulink Library Browser) 

Pojawia się puste okno do tworzenia schematu 

 

 
 

Zmiana nazwy z Untitled na docelową, np. Zbiornik_1 

File > Save as … /Zbiornik_1.mdl – rozszerzenie mdl (model) dodawane automatycznie 

 

 Umieszczenie bloków Step, Gain, Integrator, Scope 

Zaznaczyć blok w wybranej bibliotece i przeciągnąć na schemat trzymając lewy klawisz myszy 

(lkm). 

Sources > Step Continuous > Integrator 

Math Operations > Gain Sinks > Scope 

 

 
 

 

 Połączenia 

Kliknąć na wyjściu i przeciągnąć do wejścia (trzymając lkm). 
 

 
 

 Parametryzacja bloków 

2 kliknięcia bloku, wypełnić odpowiednie pola pojawiającego się okna Parameters. 

Step → b.z. Gain → Gain: 0.5 Integrator → b.z. 

Scope > 2 kl. > Ikona Parameters (druga) w oknie Scope → b.z. 
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 Opis sygnału, np. h 

Prawym klawiszem myszy (pkm) zaznaczyć połączenie > Signal Properties > Signal 

name: h (w razie potrzeby przesunąć trzymając lkm). 
 

Finalny schemat 
 

 
 

 Czas symulacji 

Simulation > Configuration Parameters: Start time: 0.0 

  Stop time: 10.0 

  Type: Variable–step (laboratorium – Fixed–step) 

Uwaga. Krok obliczeń dostosowany automatycznie (Variable–step) generuje 

ostrzeżenia (Warning) w oknie Matlaba. Nie są one jednak istotne. 

 

 Symulacja 

Ikona      lub   Simulation > Start 

2 kliknięcia bloku Scope > Ikona Autoscale (lornetka) w pojawiającym się oknie Scope. 
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ZBIORNIK Z WYPŁYWEM POD CIŚNIENIEM HYDROSTATYCZNYM 
 

 

1. Dane i model ogólny 

 

 Dane liczbowe: 
 

A= 5 m
2
 

/sm03.0/hm108

m 10

33 



wywe qq

h
 

 

 

 Model ogólny (nieliniowy) 
 

W stanie nominalnym objętość cieczy w zbiorniku nie ulega zmianie. 

 

0 wywe qq                  hgsqwy 2                    

02  hgsqwe   – równanie stanu ustalonego 

hg

q
s we

2
  

Równanie dynamiki 


nieliniowa funkcja

2ghsq
dt

dh
A we   

 

 Obliczenia dla stanu ustalonego 

 

)4.21(m00214.0
1081.92

03.0

2

22 cm  
hg

q
s we 


  

 

Pytanie. Jaki poziom uzyska się dla dopływu zmniejszonego, np. 0.02 lub 0.01 m
3
/s, 

przy takim samym stopniu otwarcia zaworu? 

 

2)(
2

1

s

q

g
h we  

 

m,45.402.0  hqwe      m,11.101.0  hqwe       )00214.0( s  

 

2. Simulink 

 

 Równanie i schemat 

 

)2(
1

ghq
Adt

dh
we   

A 

h 

qwe 

qwy 

s 

– powierzchnia swobodna zaworu na odpływie (do obliczenia) 
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Wyjaśnienia 

– Blok Step posłuży do wprowadzenia 10% zmiany dopływu (po pewnym czasie), tj.  

s/m003.0 3 weq . 

 – Nowe bloki: Sources > Constant,  Math Operations > Sum 

    Math Operations > Math Function (sqrt wybrane w parametryzacji, 

zob. niżej). 
 – Węzeł z wyprowadzeniem sygnału – Ctrl + lkm 
 

 Parametryzacja 

Bloki 

Step → Step time: 1000 – zmiana dopływu po 1000 s 

  Final value: 0.003 – %)10(weq  

Constant → Constant value: 0.03 – weq  

Gain → Gain: 81.92  – 2g 

Math Function → Function: sqrt – wybór z menu 

Gain1 → Gain: 0.00214 – s  

Sum → List of signs: I++, I+– 

Gain2 → Gain: 1/5 – 1/A 

Integrator → Initial condition: 10.0 – h , wartość początkowa odpowiadająca 

weq , względem której nastąpi zmiana poziomu. 

Scope > 2 kl. > Ikona Parameters (druga)  → Number of axes: 2 – dwa wykresy; 

parametryzację Scope zaleca się przeprowadzić przed łączeniem bloków. 
 

Czas symulacji 

Simulation > Configuration Parameters > Stop time: 20000 – dobrany po próbach 

 Simulation > Start 
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Wzrost poziomu o ponad 2 m po czasie około 17000 s (4.7 godz.) 

 

 Mniejszy dopływ 
 

1) 02.0weq   –  Constant,         m45.4h   – Integrator/Initial condition 

 

 
 

Wzrost poziomu o około 1.5 m po czasie 14000 s (3.9 godz.) 

2) 01.0weq ,    m11.1h   

 

 
 

Wzrost poziomu o około 0.8 m po czasie 7500 s (2.1 godz.) 

 

Własności dynamiczne obiektów sterowania opisanych nieliniowymi równaniami 

różniczkowymi zmieniają się wraz z punktem pracy. 

 

Regulatory stroi się dla nominalnego punktu pracy. W przypadku, gdy punkt pracy się 

zmienia (podczas tzw. regulacji programowej) nastawy regulatora powinny być do 

niego dostosowywane (gain scheduling).  

 

 

3. Linearyzacja modelu dynamiki 

 

 Niewielkie przyrosty 

 

),()( thhth       ),()( tqqtq wewewe          ),()( tssts   

 
 

W celu przybliżenia funkcji nieliniowej przez funkcję liniową należy zastosować 

rozwinięcie w szereg Taylora dla stanu nominalnego. 
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 Schemat blokowy 

 

 

 

 

 
Obiekt inercyjny I-go rzędu 

 

 

 

 

4. Obliczenia i przekształcenia 

 

 Stała czasowa i wzmocnienia 

 

s 3336
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1081.92
5

2







gs

hg
AT  

s
gs

hg
k /mm 667

2 3

1  ,         
2

2 m/m 4673
00214.0

1022





s

h
k  

sqh
dt

hd
we 


46736673336  –  czas w sekundach 

 

 Zmiana skali czasu 
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dt

hd h
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3600
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3600
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  –  czas w godzinach 
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 Jednostki względne (normalizacja) 
 

h

h
y


  –  wyjście  (zmienna procesowa) 
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we
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  –  sterowanie,      
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  –  zakłócenie 
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0.10.2926.0   

 

 Schemat blokowy 
 

 

 

 

 

 

Model zbiornika po przeskalowaniu czasu i normalizacji zmiennych 

(obiekt inercyjny) 
 

Po przeskalowaniu czasu i normalizacji zmiennych (jednostki względne) współczynniki 

w równaniu stają się rzędu 1. Jest to istotne dla implementacji w sterowniku ze względu 

na dokładność obliczeń numerycznych. 
 

Zmiana średniego poziomu w zbiorniku, tzn. punktu pracy, powoduje 

zmianę współczynników transmitancji ze względu na nieliniowość modelu. 

Układ ze sprzężeniem zwrotnym powinien być do pewnego stopnia odporny 

na te zmiany.  

 

 Matlab 

l= 2 

m= [0.926  1] 

t= 0:0.1:10; 

y= step (l,m,t); 

plot (t, y), grid 

 

 
 

Powszechnie przyjmuje się, że odpowiedź obiektu inercyjnego ustala się po czterech 

stałych czasowych. 
 

 Zależność poziomu od stopnia otwarcia zaworu na odpływie: 

1)(

)( 2








Ts

k

sS

sH
 

19260

1

s.
 

    1.0 

    2.0 
- u 

z 

y 



12 

 Simulink 

 

 
 

 

Continuous > Transfer Fcn 

Numerator coefficient: [1] 

Denominator coefficient: [.926 1] 

 
 

 

BILANS ENERGII – PODGRZEWACZ 
 

1. Równanie bilansu 
 

 Bilans energii stosuje się do tworzenia modeli matematycznych takich obiektów jak 

piece, suszarnie, reaktory, wymiennikownie, podgrzewacze itp. 
 

,TcME   

gdzie: 

E - energia,  - gęstość 

M - masa ( VM  ), T - temperatura 

V - objętość obiektu, c - ciepło właściwe 

 

Równanie bilansu można przedstawić jako: 

 

PTcqTcq
dt

dT
cV

dt

dE

j

jjjj

i

iiii     

 

P  - moc doprowadzona lub odprowadzona 

 

2. Podgrzewacz elektryczny 
 

 Dane liczbowe: 

  

 

 

 

 

 

 

 

 

 

 

  
                                        

U 

P,R 

, c, V, T 
q 

q 

, c, T0 , c, T 

V    250 

K J/kg    10 19 . 4 

kg/m    10 

  0.12 

C 60 

C 20 

m   01 .

0

\ 

0. 

3 

3 3 

0 

3 

 

  

 

 

  

  

 

U 

c 
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T 

T 

V 

 

( =10 l ) 

( = 2 l/min ) 0.0 /h m 3  /s m    10 333 3 3   



 

13 

 Warunki nominalne 

00  PTcqTcq   

 

Bilans dynamiczny 
 

 

 

 Obliczenia dla warunków nominalnych 







2.11
)2060(1019.410100333.0

250
)(

333

2

0

2

RTTcq
R

U
P   

Pytanie. Jaką temperaturę uzyska się przy napięciu U=150 V? 

0

21
T

R

U

cq
T 


,            CTU 4.34V150   – znaczny spadek temperatury 

 Simulink 

])([
1 2

0
R

U
TTcq

cVdt

dT
 


 

 

 
 

Step → Step time: 200, Final value: 25 – 10% z V250U  

Gain → 2.11/1  – 1/R 

Gain1 → )1000*19.4*1000*01.0/(1  – 1/ )( cV  

Gain2 → )1000*19.4*1000*001.0*0333.0  – cq  

Simulation → Step time 2000 

 

R

U
TcqTcq

dt

dT
cV

2

0  
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Wzrost o około 8ºC w ciągu 1400 s. 

Mniejsze napięcie: V150U  – Constant,    Integrator/Initial condition: 34.4 

 

 
 

Wzrost o ponad 5ºC w ciągu około 1400 s. 
 

 

3. Linearyzacja 
 

 

 

 

 Prawa strona bilansu jest nieliniowa, więc należy ją rozwinąć w szereg Taylora 

względem T, q, U, T0. 

U
R

U
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dt

Td
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Transformacja Laplace’a 
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 Schemat blokowy 

 
Model podgrzewacza (obiekt inercyjny) 

 

 

 

 

 

 

 

 

4. Obliczenia 

 

 Stała czasowa i wzmocnienia 

/smK102.1
100333.0
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KW58.5W5580
2.11

250
VK32.0
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P        ,/k
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 Zmiana jednostek   –   czas w minutach,   przepływ w  m
3
/h 

UTqT
dt

Td
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dt
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h

h
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 Matlab 

l= 0.32 

m= [5 1] 

t=0:0.3:30; 

y= step (l,m,t); 

plot (t,y), grid 

 
 

 
 

Simulink – jak poprzednio. 
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OPÓŹNIENIE 
 

1. Transport 
 

 W większości procesów technologicznych występuje transport cieczy, gazów, 

materiałów sypkich itp. (rurociągi, taśmociągi, podajniki). Pojawia się problem – jak 

transport uwzględnić w transmitancji? (opóźnienie transportowe) 

Również przenikanie ciepła przez ściany, mieszanie, dyfuzja itp. odbywa się ze 

skończoną prędkością. 
 

 

 

 

 

 

 

 

 

Opóźnienie transportowe w kotle rusztowym. 

 

2. Transmitancja i aproksymacja Padé 

 

 Transmitancja transcedentna 

 

)()(  tuty ,         τsesUsY  )()(  

Opóźnienie jako transmitancja transcedentna 

 

 

 

 Aproksymacja opóźnienia – przybliżenie Padé 

 Matlab – pade 12,...,1),,( nn  
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Uwaga. Symulacja czasowa samego opóźnienia w Matlabie daje dobre wyniki tylko dla 

gładkich wymuszeń (np. sinusoida). Dla wymuszeń ze skokami, ostrzami itp. (jak 

wyżej) występują spore rozbieżności. Znacznie lepiej będzie wyglądać symulacja 

układu ze sprzężeniem zwrotnym. 
 

Transmitancje obiektów technologicznych (energetycznych, chemicznych 

i in.) należy zwykle uzupełnić o pewne opóźnienie, co daje:  

 
,
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se
Ts
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21

se
sTsT




 

Bardzo często wartość  określa się eksperymentalnie. 

 

 Simulink 

 
 

Continuous > Transport Delay 

 Time delay: 0.5 

Step > Step time: 0 

Transmitancja przykładowa – 

s

ss

0.5

2
e

12

1 


 

 

 Matlab 
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NAPIĘCIOWE STEROWANIE SILNIKIEM DC 
 

1. Silnik prądu stałego (Direct Current) 

 

 Zastosowanie: starsze napędy obrabiarek, robotów, rejestratorów, suwnic itd. ze 

sterowaniem poprzez napięcie wirnika. Napędy małej mocy sterowane wprost z układu 

scalonego. 

Wadą silników prądu stałego jest stosowanie komutatora. Obecnie zaczynają  

przeważać silniki bezkomutatorowe (odpowiedni materiał magnetyczny wirnika i 

elektroniczny sterownik impulsowy dla stojana).  
 

 

 

 

 

 

 

 

 

 

 

Zasilanie napięciem U generowanym przez sterownik za pośrednictwem wzmacniacza 

mocy.  

2. Uproszczony opis silnika DC 
 

 Równanie napięć 

iRSEMU   

Dla potrzeb modelowania w automatyce pomija się indukcyjność wirnika (L  0). 
 

 Równanie momentów 




DMM
dt

d
J oem   

gdzie: 

D – współczynnik tarcia, R – rezystancja komutatora 

J – moment bezwładności, Mem    – moment elektromagnetyczny 

 – prędkość kątowa, Mo       – moment obciążenia 

 – kąt.  

 

Ponadto 

,scSEM         ,ikM sem         0D  

 

 Przekształcenia 

Chodzi o utworzenie równań wiążących prędkość  z napięciem U i momentem 

obciążenia Mo. 

Z równania napięć wyznacza się prąd i podstawia do równania momentów 
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Transformacja Laplace’a 
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Ostatecznie 
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Jest to transmitancja inercyjna, podobnie jak w przypadku zbiornika i podgrzewacza. 

 

 Schemat blokowy 
 

 

 

 

 

 

Model silnika sterowanego napięciowo 

Jeśli  Mo = 0, to: 

1)(

)(
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Transmitancje całkiem różnych obiektów fizycznych mogą mieć ten sam charakter. 

Zatem w jednolity sposób można analizować i projektować układy, które nimi sterują 

(mówi się więc o interdyscyplinarności automatyki). 
 

 

 

3. Wyznaczanie transmitancji na podstawie danych znamionowych 
 

 Dane liczbowe: 

UN =  24 V 

nN =  3000 obr/min 

PN =  100 W 

R =  1  

J =  0.004 kg m
2
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 Stan jałowy (bez obciążenia) 
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 Stan nominalny 
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Wniosek.  Jeżeli napięcie U zwiększymy o 1V, to obroty wzrosną o 13.1 rd/s. 

 Transmitancja silnika względem kąta  (położenie) 

dt

d
  ,      )(ssΦΩ       
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Φ  

 1Tss

k
 –  transmitancja całkująca z inercją I rzędu 

 

Dla danych z przykładu 
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 Matlab 

l= 13.1 

m= [0.69  1] 

t= 0:0.05:5; 

om= step (l, m, t); 

fi= step (l, [m  0], t); 

plot (t, om, t, fi), grid 
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 Simulink 

 
 

 

Multiplekser –  dwa wykresy w oknie 

Signal Routing > Mux 

 

 

 

STEROWANIE PRĄDOWE 
 

 

 

1. Układ 
 

 Prąd i jest ustawiany przez 

sterownik za pośrednictwem 

wzmacniacza mocy pracującego 
w układzie źródła prądu. 

 

 

 

Regulowanym źródłem prądu jest następujący układ: 
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Wzmacniacz z prądowym sprzężeniem zwrotnym 

 

 

2. Opis 
 

 Teraz korzysta się tylko z równania momentów 
 




DMM
dt

d
J oem   , 

gdzie  ikM sem  ,   D0  

os Mik
dt

d
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 Transformacja Laplace’a 

)()()( sMsIkssJ os Ω  

Js

sM
sI

Js

k
s os )(

)()( Ω    -   transmitancja całkująca 

 Schemat blokowy 
 
 

 

 

 

 

 

Istnieje szereg obiektów opisanych przez transmitancję całkującą (jak choćby zbiornik 

zamknięty). 

 Położenie  

)()( sΦss Ω ,    
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 Schemat blokowy 
 

 

 

 

 

 
 

Sterowanie prądowe uważa się za odpowiedniejsze niż sterowanie napięciowe ponieważ 

podwójne całkowanie zapewnia lepszą dokładność śledzenia zmieniającej się wielkości 

zadanej. Obecnie jest ono powszechnie stosowane. 
 

Dane z poprzedniego przykładu: 
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 Matlab 

l=19 

m= [1 0] 

t=0:0.05:5; 

om= step (l, m, t); 

fi= step (l, [1  0  0], t); 

plot (t, om, t, fi), grid 

 

Chcąc zatrzymać silnik należy zmienić kierunek prądu.  

Ogólnie biorąc sterowanie obiektami całkującymi (astatycznymi) wymaga nieco bardziej 

zaawansowanych algorytmów niż sterowanie obiektami inercyjnymi (statycznymi). 

– transmitancja podwójnie 

całkująca (podwójny integrator) 
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